找回密码
 立即注册

Qt在VS2013中的程序框架搭建

发表于 2017-12-6 23:04:33 | 显示全部楼层 |阅读模式
1Qter豆
本帖最后由 许独 于 2017-12-6 23:05 编辑

  大佬们,萌新来提问了~  在电脑上,各类条件都安装完毕后,用的是VS2013和Qt5.8,插件也安装完成。
  主要是,我的上述软件VS2013和Qt5.8都在E盘(为了不影响运行内存),那么问题来了,是否能将他们安装在除了C盘的地方呢?
  还有还有,然后尝试做一个Hello world的基本程序,然后出现如下的编程问题,但我认为是框架问题,想请教大佬们一下:
  


  图中的那个不匹配项是什么意思啊?配置问题还是电脑问题呢?


附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
回复

使用道具 举报

发表于 2017-12-7 16:11:47 | 显示全部楼层
编译器版本问题
MS VC++ 14.0 _MSC_VER = 1900 (Visual Studio 2015)
MS VC++ 12.0 _MSC_VER = 1800 (VisualStudio 2013)

就编译出来的链接文件lib、dll是用VC12编译出来的,而现在你用VC14编译器所以不成功。
回复

使用道具 举报

 楼主| 发表于 2017-12-8 20:06:43 | 显示全部楼层
a2583211 发表于 2017-12-7 16:11
编译器版本问题
MS VC++ 14.0 _MSC_VER = 1900 (Visual Studio 2015)
MS VC++ 12.0 _MSC_VER = 1800 (Visua ...

哦~原来如此,那么请问是需要重新下载VS2015嘛?可是网上为什么说QT5.8的适配VS2013呢?按照这个说法的话,我是需要下载VS2015吗?对了,还有啊,那个我将他们安装在E盘没事吧~
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

许独

    主题

    帖子

    10

    积分

    Qter1级会员

    Rank: 1

    积分
    10

Qter1级会员

发私信

Qt开源社区——开源 共享 自由

微信扫一扫
查看精品教程!