找回密码
 立即注册
收起左侧

Ubuntu安装qt-opensource-linux-x64-5.11.1

2
回复
4168
查看
[复制链接]
累计签到:480 天
连续签到:1 天
来源: 原创 2018-8-17 08:12:17 显示全部楼层 |阅读模式

马上注册,查看详细内容!注册请先查看:注册须知

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 Future 于 2018-11-1 09:09 编辑

登陆qt官方下载页面:http://download.qt.io/archive/qt/

本文以安装qt-opensource-linux-x64-5.11.1为例。
把下载好的qt-opensource-linux-x64-5.11.1.run放进Linux系统里。首先给qt-opensource-linux-x64-5.11.1.run运行权限,再运行。

sudo chmod +x qt-opensource-linux-x64-5.11.1.runlssudo ./qt-opensource-linux-x64-5.11.1.run




选择软件存储目录,最好选择默认目录

选择安装组件,可以只安装三个红色方框,最好全选。



点击安装之后,需要等待一段时间安装完成。

在命令行中输入:sudo gedit /usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf
打开default.conf文件,

将第一行改为bin目录的路径,第二行改为qt5.8.0目录的路径,然后保存退出。


在安装目录找到qtcreator,双击打开qtcreator。


可以直接把qtcreator固定在工具,为了下次方便打开。

现在,新建一个工程helloword,测试一下。


设置项目名称和项目路径。




点击运行

如果出现:-1: error: cannot find -lGL错误,那是没有安装libgl1-mesa-dev


sudo apt-get install libgl1-mesa-dev
执行sudo apt-get install libgl1-mesa-dev完成后,回到qtcreator界面,重新运行项目,就出现mainWindow界面了。至此,qt-opensource-linux-x64-5.11.1算是安装成功了。

回复

使用道具 举报

累计签到:284 天
连续签到:1 天
2018-8-17 21:14:03 显示全部楼层
现在deepin都5.10.1了,乌班图还是老版吗?话说5.11.1没有什么新功能吧

点评

Qt5.11的一个重点就是Windows的可访问性(accessibility)支持。根据微软的UI Automation,Qt5.11在Windows的可访问性部分基本完全重写了。因此极大的改进了对Windows可访问性的支持。(Microsoft UI Automation) 除  详情 回复 发表于 2018-8-20 07:59
回复 支持 反对

使用道具 举报

累计签到:480 天
连续签到:1 天
2018-8-20 07:59:59 显示全部楼层
幽弥狂 发表于 2018-8-17 21:14
现在deepin都5.10.1了,乌班图还是老版吗?话说5.11.1没有什么新功能吧

Qt5.11的一个重点就是Windows的可访问性(accessibility)支持。根据微软的UI Automation,Qt5.11在Windows的可访问性部分基本完全重写了。因此极大的改进了对Windows可访问性的支持。(Microsoft UI Automation)
除此之外,改进了对Windows中控件(部件)样式(风格)高DPI的支持。Linux系统中的打印窗口也进行了大改,为所有的选项提供了更好的支持。并且修复了Qt中的控件的大量BUG。所以这次更新对于桌面开发者来说是一次Very Nice的更新。

另外,Ubuntu16.04挺好用的。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册