找回密码
 立即注册
收起左侧

QT4移植到Qt5时,3D动态库编译问题,求大佬帮忙解决

0
回复
165
查看
[复制链接]

尚未签到

来源: 2021-4-29 11:52:05 显示全部楼层 |阅读模式
9Qter豆
工程项目之前是vs2008+Qt4.7的一个环境,现在想要移植到vs2019+Qt5.15上,编译公司提供的3d动态库时,一个qarray.h的文件,内部定义了template <typename T, int PreallocSize> class  QArrayData的模板类:
但是编译的时候一直报错“QArrayData”: 类模板已经声明为非类 模板,根据提示是在D:\Qt\5.15.2\msvc2019_64\include\QtCore\qarraydata文件中出现了 struct Q_CORE_EXPORT QArrayData 的声名,


这个怎么解决?

附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册